Reef Central Online Community

Home Forum Here you can view your subscribed threads, work with private messages and edit your profile and preferences View New Posts View Today's Posts

Find other members Frequently Asked Questions Search Reefkeeping ...an online magazine for marine aquarists Support our sponsors and mention Reef Central

Go Back   Reef Central Online Community > General Interest Forums > Lighting, Filtration & Other Equipment
Register Blogs FAQ Calendar Mark Forums Read

Notices

User Tag List

Reply
Thread Tools
Old 05/04/2014, 08:00 AM   #126
d2mini
Registered Member
 
d2mini's Avatar
 
Join Date: Nov 2008
Location: Houston, TX
Posts: 10,344
Quote:
Originally Posted by clugo View Post
I have a few question for my Lifereef family:

1. How often do u clean ur skimmer cup and neck?

For those who also one a Lifereef calcium reactor:
2. Did u install a check valve on the line from the co2?

3. Did u install a needle valve to control the output from the reactor ?

If so , did they come w the reactor?

Thanks for ur help.
1. Maybe once a month. Every few days I empty it using the valve on the cup.
2. ?
3. ?

The last two sound like you are asking about a calcium reactor.
There is no co2 or needle valve.


__________________
-dennis

Elos Diamond 120xl | Elos Stand | Radion G4 Pros | GHL Profilux Controller | LifeReef Skimmer | LifeReef Sump
Photos taken with a Nikon D750 or Leica M.
d2mini is offline   Reply With Quote
Old 05/04/2014, 08:05 AM   #127
clugo
Registered Member
 
Join Date: Aug 2010
Posts: 537
thanks!!

Yeah, my last two questions had to do w a LR calcium reactor. I'm about to get mine online; hopefully this week. I had noticed people mentioning these two items in either youtube videos or in posts on RC but i didn't notice either on Jeff's site.

thanks again.


clugo is offline   Reply With Quote
Old 05/04/2014, 12:31 PM   #128
WestTexasReefer
Registered Member
 
Join Date: Sep 2009
Location: Lubbock, Texas
Posts: 243
I have a Sicce Syncra 4.0 on my vs-24 and it works great. It is definitely quieter than the Mag 9.5.


__________________
Jeff

Current Tank Info: 180 gallon brick with Aqua Illumination LED lights
WestTexasReefer is offline   Reply With Quote
Old 05/05/2014, 07:25 PM   #129
skinsncanes
Registered Member
 
Join Date: May 2014
Posts: 156
Quote:
Originally Posted by Ragga View Post
VS3-30 (external) or SVS3-30 (in sump).
Best bet would be to give Jeff a call and discuss your needs. He will spend as much time with you as needed. His customer service is second to none.
Just had a solid 90 minute phone call with Jeff. Learned a lot.

Checking wallet now....

Im leaning towards his skimmer and wet dry filter. trying to get my tank right the first time.


skinsncanes is offline   Reply With Quote
Old 05/05/2014, 07:28 PM   #130
clugo
Registered Member
 
Join Date: Aug 2010
Posts: 537
The Life Reef Skimmer Club

I've owned reef octopus and deltec; Jeff's skimmer has blown both of them away. I currently have his vs24 and it's by far the best skimmer I've owned. I'd highly recommend it!


clugo is offline   Reply With Quote
Old 05/05/2014, 07:47 PM   #131
kris101
Registered Member
 
kris101's Avatar
 
Join Date: Apr 2003
Location: Amherst, Ohio
Posts: 843
Quote:
Originally Posted by skinsncanes View Post
Im leaning towards his skimmer and wet dry filter. trying to get my tank right the first time.
You won't go wrong with Lifereef! Great Choice


__________________
Marineland 300 DD peninsula

Current Tank Info: 300 DD, Bubble King Supermarin 200, Kessil + T-5 Lighting.
kris101 is offline   Reply With Quote
Old 05/05/2014, 09:08 PM   #132
Speed
Unregister Member
 
Speed's Avatar
 
Join Date: May 2010
Location: Outside of Philly
Posts: 195
Quote:
Originally Posted by skinsncanes View Post
Just had a solid 90 minute phone call with Jeff. Learned a lot.
Yes Sir, Jeff is one of the good ones.
As others have said...you won't be disappointed.


__________________
Good Things Happen Slowly..... Bad Things Happen Fast!

Current Tank Info: Slowest 125g build in history
Speed is offline   Reply With Quote
Old 05/06/2014, 02:21 AM   #133
Flosscadub
Registered Member
 
Join Date: May 2012
Posts: 20
Quote:
Originally Posted by d2mini View Post
This is the latest pic i have.
It's been like 10 months or so and the skimmer hasn't missed a beat!

This might be a dumb question
How did you connect you union to the Venturi?
They're both female?
I can't seem to find a double male connector
I've found what is called a riser, but it leaks(not sch40)
Plz advise
Sorry if it's an idiotic question
Thanks


Flosscadub is offline   Reply With Quote
Old 05/06/2014, 10:24 AM   #134
dcmartinpc
Registered Member
 
Join Date: Oct 2006
Location: Niles, MI
Posts: 331
Quote:
Originally Posted by Flosscadub View Post
This might be a dumb question
How did you connect you union to the Venturi?
They're both female?
I can't seem to find a double male connector
I've found what is called a riser, but it leaks(not sch40)
Plz advise
Sorry if it's an idiotic question
Thanks

Looks like it might be 1" or 3/4" PVC, just cut a short piece and glue it together.

I may be wrong, please advise if otherwise.

Don


__________________
I glue animals to rocks...

Current Tank Info: 225G 5x3x2, 2 x 400w Radium on Dual PFO HQI, 2-Blue+, 2-Actinic, 2 x MP40w ES, 2 x Maxspect Gyre and 60 Cube LPS, 6-Blue+, 2-Purple+, 2xMP40w ES. Common 150 Rubbermaid sump. All driven with an Apex.
dcmartinpc is offline   Reply With Quote
Old 05/06/2014, 10:36 AM   #135
ken6217
Registered Member
 
Join Date: Oct 2006
Location: NJ
Posts: 2,179
Quote:
Originally Posted by Flosscadub View Post
This might be a dumb question
How did you connect you union to the Venturi?
They're both female?
I can't seem to find a double male connector
I've found what is called a riser, but it leaks(not sch40)
Plz advise
Sorry if it's an idiotic question
Thanks
I have the mazzei venturi which is male on both sides. If yours are female threaded on both sides, get two MPT/slip. Thread the male ends into the two female. Then cut a short piece of PVC and glue the two together.

You can also call Jeff. He would have put the piece you are looking for in with the shipment. I'm sure he will send you another.

Here is a couple of pictures of what they look like.
Ken







Last edited by Dino; 04/06/2018 at 05:49 AM.
ken6217 is offline   Reply With Quote
Old 05/07/2014, 10:12 AM   #136
bawalitt
Registered Member
 
Join Date: Mar 2014
Posts: 26
New lifereef svs3-30

Just got my new Lifereef 30" skimmer two days ago. The build quality is excellent and great attention to detail. I got mine with a Mazzi venturi.

Its plumbed outside the sump with a mag 12 supplying water to it.

Its been two days and looks like its still breaking in. It has not produced any foam head or skimmate.

Want to ask the members out there if they can share their experience re. the skimmers break-in period.

Cheers


bawalitt is offline   Reply With Quote
Old 05/07/2014, 10:15 AM   #137
clugo
Registered Member
 
Join Date: Aug 2010
Posts: 537
Ive had mine for about 2.5 wks and its done great. It took a couple of days to really start skimming well. It was a little wet before I dialed it in a little better but that was ok since I just changed all my LR.


clugo is offline   Reply With Quote
Old 05/07/2014, 10:43 AM   #138
kris101
Registered Member
 
kris101's Avatar
 
Join Date: Apr 2003
Location: Amherst, Ohio
Posts: 843
Quote:
Originally Posted by bawalitt View Post
Want to ask the members out there if they can share their experience re. the skimmers break-in period.
Did you give it a vinegar bath 1st? Break in can very. Mine took about a week and a half on a new tank. I have read others only taking hours. I know that New saltwater will prolong the breaking period as there is a lot of surface tension.


__________________
Marineland 300 DD peninsula

Current Tank Info: 300 DD, Bubble King Supermarin 200, Kessil + T-5 Lighting.
kris101 is offline   Reply With Quote
Old 05/07/2014, 10:47 AM   #139
d2mini
Registered Member
 
d2mini's Avatar
 
Join Date: Nov 2008
Location: Houston, TX
Posts: 10,344
Mine went from the box, straight into my tank and was producing foam within 12 hours.
Since then I have done deep cleanings/vinegar baths and it still starts skimming quickly.
What's your water level set to in the skimmer body?

Mine is plumbed inside the sump, so not sure what difference there is in setup/water level vs being plumbed outside the sump.


__________________
-dennis

Elos Diamond 120xl | Elos Stand | Radion G4 Pros | GHL Profilux Controller | LifeReef Skimmer | LifeReef Sump
Photos taken with a Nikon D750 or Leica M.
d2mini is offline   Reply With Quote
Old 05/07/2014, 10:59 AM   #140
ken6217
Registered Member
 
Join Date: Oct 2006
Location: NJ
Posts: 2,179
Quote:
Originally Posted by bawalitt View Post
Just got my new Lifereef 30" skimmer two days ago. The build quality is excellent and great attention to detail. I got mine with a Mazzi venturi.

Its plumbed outside the sump with a mag 12 supplying water to it.

Its been two days and looks like its still breaking in. It has not produced any foam head or skimmate.

Want to ask the members out there if they can share their experience re. the skimmers break-in period.

Cheers
We have the same setup. Each tank is different in terms of how long it takes for a skimmer to breakin. I did have a foam head within that time period on mine. it didn't have any real color to speak of, but it did have a foam head.

Where do you have the level set in relation to the top flange?
Ken


ken6217 is offline   Reply With Quote
Old 05/07/2014, 04:39 PM   #141
bawalitt
Registered Member
 
Join Date: Mar 2014
Posts: 26
Quote:
Originally Posted by ken6217 View Post
We have the same setup. Each tank is different in terms of how long it takes for a skimmer to breakin. I did have a foam head within that time period on mine. it didn't have any real color to speak of, but it did have a foam head.

Where do you have the level set in relation to the top flange?
Ken
Thanks for the replies guys,

Well mine is setup outside the sump, on a small stool. The water level inside the skimmer is approx. 1" below the flange.

At work right now, but once i get home I will be able to update you guys on the progress.

One thing i did that i think could be causing a delayed response, is that i installed that foam pad at the bottom of the Mag 12 (it comes with it) to reduce the vibrations.

My bio load is pretty heave. My Tunze was skimming some nog before i installed this skimmer, now because of the change in water tension my tunze is also not skimming. lol.


bawalitt is offline   Reply With Quote
Old 05/07/2014, 04:42 PM   #142
bawalitt
Registered Member
 
Join Date: Mar 2014
Posts: 26
Quote:
Originally Posted by kris101 View Post
Did you give it a vinegar bath 1st? Break in can very. Mine took about a week and a half on a new tank. I have read others only taking hours. I know that New saltwater will prolong the breaking period as there is a lot of surface tension.

No i did not give it a vinegar bath. In the hind sight i should have done it.

Another thing i forgot to mention, I put some sylicone greese which came with the skimmer on the rubber gasket. Dont know if thats causing it to not foam.


bawalitt is offline   Reply With Quote
Old 05/07/2014, 04:47 PM   #143
bayoupr
Registered Member
 
bayoupr's Avatar
 
Join Date: Oct 2008
Location: Louisiana
Posts: 1,308
Give it time, it will produce. I just set up a 30" yesterday and as of now, slight foam. But I know it will pickup because my 48" did the same. By morning mine should be foaming (usually takes about 24-36hrs). Some people have theirs skimming within 12hrs or so.


bayoupr is offline   Reply With Quote
Old 05/07/2014, 04:47 PM   #144
ken6217
Registered Member
 
Join Date: Oct 2006
Location: NJ
Posts: 2,179
Raise the water level to just about where the flange is. You should get water-bubbles in the neck. It make just look like boiling water at first but then you will get foam.


ken6217 is offline   Reply With Quote
Old 05/07/2014, 04:48 PM   #145
bobbyc366
Registered Member
 
Join Date: Oct 2013
Location: Oshkosh WI
Posts: 86
Quote:
Originally Posted by bawalitt View Post
No i did not give it a vinegar bath. In the hind sight i should have done it.

Another thing i forgot to mention, I put some sylicone greese which came with the skimmer on the rubber gasket. Dont know if thats causing it to not foam.
Just give some time they are a beast, I also use the silicone, keep the water leaves about a inch or so from the flange and let it do it's thing.


bobbyc366 is offline   Reply With Quote
Old 05/07/2014, 05:07 PM   #146
ksed
Registered Member
 
Join Date: Sep 2007
Posts: 1,867
Silicone will definitely do it. Especially if you accidentally got some when water can come in contact with the silicone.Not sure if it will work but try to run some new carbon.



Quote:
Originally Posted by bawalitt View Post
No i did not give it a vinegar bath. In the hind sight i should have done it.

Another thing i forgot to mention, I put some sylicone greese which came with the skimmer on the rubber gasket. Dont know if thats causing it to not foam.



ksed is offline   Reply With Quote
Old 05/07/2014, 05:57 PM   #147
bawalitt
Registered Member
 
Join Date: Mar 2014
Posts: 26
Well jut got home and checked the skimmers. The Tunze 9430 has a foam head and is lightly skimming But the Lifereef is still just booking water.
I will run some new carbon through it, hopefully that helps.


bawalitt is offline   Reply With Quote
Old 05/07/2014, 06:09 PM   #148
bawalitt
Registered Member
 
Join Date: Mar 2014
Posts: 26
Just added 1.5 cups of fresh carbon. Let's see if that helps


bawalitt is offline   Reply With Quote
Old 05/07/2014, 06:12 PM   #149
ken6217
Registered Member
 
Join Date: Oct 2006
Location: NJ
Posts: 2,179
Quote:
Originally Posted by bawalitt View Post
Well jut got home and checked the skimmers. The Tunze 9430 has a foam head and is lightly skimming But the Lifereef is still just booking water.
I will run some new carbon through it, hopefully that helps.
Why are you running two skimmers? Your Lifereef is competing for the same dissolved organics.


ken6217 is offline   Reply With Quote
Old 05/07/2014, 06:31 PM   #150
bawalitt
Registered Member
 
Join Date: Mar 2014
Posts: 26
Well I was going to take the Tunze off line as soon as the Lifereef broke in, but they both stopped working because of the chemicals released by the Lifereef skimmers glue or something


bawalitt is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -6. The time now is 08:52 AM.


TapaTalk Enabled

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Use of this web site is subject to the terms and conditions described in the user agreement.
Reef CentralTM Reef Central, LLC. Copyright 1999-2014
User Alert System provided by Advanced User Tagging v3.3.0 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.